FAQs
  • 28 Nov 2022
  • 2 Minutes to read
  • Dark
    Light

FAQs

  • Dark
    Light

Frequently Asked Questions (FAQs) for Developers


Our project has been developed with Swift 3.0. We cannot import TenjinSDK in AppDelegate.swift.

  • iOS development is done by Objective-C or Swift. If you use Swift, you need to implement this special setting. In order to make this work, under “Build Settings” -> “Swift Compiler - General”, add the bridge header.
  • Here is Apple's documentation.
  • We also uploaded the sample project so you can reference it.

Can we remove the reference to older version of Google play service in Manifest file?

  • Yes, you can remove the following line from Android Manifest file.
    <meta-data android:name="com.google.android.gms.version" android:value="@integer/google_play_services_version" />
    

How can I resolve this error when trying to build an Android app with Tenjin SDK?

Execution failed for task ':transformClassesWithDexForRelease'.
com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.dex.DexException: Multiple dex files define Lcom/google/android/gms/actions/ItemListIntents;
  • This error happens when you have a different version of Google Play Service library. Remove the following library to resolve:
    • /Assets/Plugins/Android/play-services-basement-11.0.4.aar

I see the following bit code error when trying to archive build for iOS.

ld: warning: arm64 function not 4-byte aligned: ltmp0 from /Users/shayashi23/Workspace/UnityProjects/cultura02/Builds/ios2.1.0_tenjin_transfer_mediation/Libraries/libiPhone-lib.a(unwind_test_arm64.o)
ld: warning: arm64 function not 4-byte aligned: _unwind_tester from /Users/shayashi23/Workspace/UnityProjects/cultura02/Builds/ios2.1.0_tenjin_transfer_mediation/Libraries/libiPhone-lib.a(unwind_test_arm64.o)
ld: could not reparse object file in bitcode bundle: 'Invalid bitcode version (Producer: '1000.11.45.2_0' Reader: '902.0.39.2_0')', using libLTO version 'LLVM version 9.1.0, (clang-902.0.39.2)' for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
  • This happens when Xcode version is old. You need to upgrade Xcode to the latest version, as described here.

I see Android minSdkVersion is 21, why?

  • We started supporting two SDKs for Android other app stores, MSA OAID SDK (minSdkVersion is 21 for version 1.0.25), Huawei referrer SDK (minSdkVersion is 19). Both these SDKs required us to update the minSdkVersion from 16 to 19 and 19 to 21 repectively. This is the reason for tenjin to have minSdkVersion as 21.
  • If you need to have the latest SDK but don't intend to integrate Huawei referrer SDK and MSA OAID SDK, then try to use this branch.

I can't make your Tenjin AdobeAir integration work, do you have a plugin I can use?

  • Some of our customers are using this plug-in. Please note that this plugin has not been built by Tenjin.

I see a Unity import error message 'Unity infinite import loop has been detected. The following Assests were imported multiple times.' How do I fix this?

This can be fixed by removing the edtior folder. If it's still not solved, please write to us at support@tenjin.com with details.



Was this article helpful?

What's Next